nix-config/options.nix
2024-03-13 15:29:41 +01:00

10 lines
437 B
Nix

{ lib, ... }: {
options = {
withNiri = with lib; mkEnableOption "Enable niri compositor";
withGnome = with lib; mkEnableOption "Enable gnome DE";
withNvidia = with lib; mkEnableOption "Enable proprietary nvidia drivers";
withVM = with lib; mkEnableOption "Enable VM related configuration";
withDistrobox = with lib; mkEnableOption "Enable Distrobox";
withGames = with lib; mkEnableOption "Enable games";
};
}